// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(UUID\:\s([a-zA-z\d-]*)\)").unwrap();
let string = "IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}