package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(UUID\:\s([a-zA-z\d-]*)\)`)
var str = `IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}