use strict;
my $str = 'IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)';
my $regex = qr/\(UUID\:\s([a-zA-z\d-]*)\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}