const regex = /\(UUID\:\s([a-zA-z\d-]*)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(UUID\\:\\s([a-zA-z\\d-]*)\\)', '')
const str = `IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}