re = /\(UUID\:\s([a-zA-z\d-]*)\)/
str = 'IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end