using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(UUID\:\s([a-zA-z\d-]*)\)";
string input = @"IDE (0, 0): /opt/VirtualBox/Drives/IE11 - Win7/Snapshots/{4fece41a-116c-496b-ad77-49dfd017df6c}.vmdk (UUID: 4fece41a-116c-496b-ad77-49dfd017df6c)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}