import Foundation
let pattern = #"[^a-zA-Z0-9\+(\-){1,}]{1,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"some folder\Nmae B@!Q$% ~!@#$%^&*()_`1234567890-~!@#$%^&*()_+-Chara"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)