const regex = /[^a-zA-Z0-9\+(\-){1,}]{1,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9\\+(\\-){1,}]{1,}', 'g')
const str = `some folder\\Nmae B@!Q\$% ~!@#\$%^&*()_\`1234567890-~!@#\$%^&*()_+-Chara`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);