package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z0-9\+(\-){1,}]{1,}`)
var str = `some folder\Nmae B@!Q$% ~!@#$%^&*()_\`1234567890-~!@#$%^&*()_+-Chara`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}