use strict;
my $str = 'some folder\\Nmae B@!Q$% ~!@#$%^&*()_`1234567890-~!@#$%^&*()_+-Chara';
my $regex = qr/[^a-zA-Z0-9\+(\-){1,}]{1,}/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";