$re = '/[^a-zA-Z0-9\+(\-){1,}]{1,}/';
$str = 'some folder\\Nmae B@!Q$% ~!@#$%^&*()_`1234567890-~!@#$%^&*()_+-Chara';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;