using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9\+(\-){1,}]{1,}";
string substitution = @"-";
string input = @"some folder\Nmae B@!Q$% ~!@#$%^&*()_`1234567890-~!@#$%^&*()_+-Chara";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}