re = /[^a-zA-Z0-9\+(\-){1,}]{1,}/
str = 'some folder\\Nmae B@!Q$% ~!@#$%^&*()_`1234567890-~!@#$%^&*()_+-Chara'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result