// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$").unwrap();
let string = "13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}