$re = '/^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$/m';
$str = '13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);