using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$";
string input = @"13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}