import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?[0-9]+(\\.[0-9]+)?[[:space:]]?[CFcf]?$";
final String string = "13\n"
+ "102\n"
+ "97.0\n"
+ "-4.28\n"
+ "11.25\n"
+ "+8\n"
+ "0.015\n"
+ "19 c\n"
+ "19F\n"
+ "32C\n"
+ "-17.20 c\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}