use strict;
my $str = '13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
';
my $regex = qr/^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}