const regex = /^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?[0-9]+(\\.[0-9]+)?[[:space:]]?[CFcf]?$', 'gm')
const str = `13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}