package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$`)
var str = `13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}