import Foundation
let pattern = #"\/.*(?=\\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
8670 b'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\n'
8671 b'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\n'
8672 b'/home/giampaolo/Nextcloud/Komatsu.mp4\n'
8673 b'/home/giampaolo/20190609rsync_HM-1_4T\n'
8674 b'/home/giampaolo/Prada-1913_HK.ods\n'
8675 b'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\n'
8676 b'/home/giampaolo/20190915-list_of_kernels\n'
8677 b'/home/giampaolo/20190916-installed_packages\n'
8678 b'/home/giampaolo/find_3_days\n'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)