const regex = /\/.*(?=\\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/.*(?=\\\\)', 'gm')
const str = `8670 b'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\\n'
8671 b'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\\n'
8672 b'/home/giampaolo/Nextcloud/Komatsu.mp4\\n'
8673 b'/home/giampaolo/20190609rsync_HM-1_4T\\n'
8674 b'/home/giampaolo/Prada-1913_HK.ods\\n'
8675 b'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\\n'
8676 b'/home/giampaolo/20190915-list_of_kernels\\n'
8677 b'/home/giampaolo/20190916-installed_packages\\n'
8678 b'/home/giampaolo/find_3_days\\n'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}