import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/.*(?=\\\\)";
final String string = "8670 b'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\\n'\n"
+ "8671 b'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\\n'\n"
+ "8672 b'/home/giampaolo/Nextcloud/Komatsu.mp4\\n'\n"
+ "8673 b'/home/giampaolo/20190609rsync_HM-1_4T\\n'\n"
+ "8674 b'/home/giampaolo/Prada-1913_HK.ods\\n'\n"
+ "8675 b'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\\n'\n"
+ "8676 b'/home/giampaolo/20190915-list_of_kernels\\n'\n"
+ "8677 b'/home/giampaolo/20190916-installed_packages\\n'\n"
+ "8678 b'/home/giampaolo/find_3_days\\n'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}