use strict;
my $str = '8670 b\'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\\n\'
8671 b\'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\\n\'
8672 b\'/home/giampaolo/Nextcloud/Komatsu.mp4\\n\'
8673 b\'/home/giampaolo/20190609rsync_HM-1_4T\\n\'
8674 b\'/home/giampaolo/Prada-1913_HK.ods\\n\'
8675 b\'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\\n\'
8676 b\'/home/giampaolo/20190915-list_of_kernels\\n\'
8677 b\'/home/giampaolo/20190916-installed_packages\\n\'
8678 b\'/home/giampaolo/find_3_days\\n\'';
my $regex = qr/\/.*(?=\\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}