# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/.*(?=\\)"
test_str = ("8670 b'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\\n'\n"
"8671 b'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\\n'\n"
"8672 b'/home/giampaolo/Nextcloud/Komatsu.mp4\\n'\n"
"8673 b'/home/giampaolo/20190609rsync_HM-1_4T\\n'\n"
"8674 b'/home/giampaolo/Prada-1913_HK.ods\\n'\n"
"8675 b'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\\n'\n"
"8676 b'/home/giampaolo/20190915-list_of_kernels\\n'\n"
"8677 b'/home/giampaolo/20190916-installed_packages\\n'\n"
"8678 b'/home/giampaolo/find_3_days\\n'")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.