re = /\/.*(?=\\)/m
str = '8670 b\'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\\n\'
8671 b\'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\\n\'
8672 b\'/home/giampaolo/Nextcloud/Komatsu.mp4\\n\'
8673 b\'/home/giampaolo/20190609rsync_HM-1_4T\\n\'
8674 b\'/home/giampaolo/Prada-1913_HK.ods\\n\'
8675 b\'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\\n\'
8676 b\'/home/giampaolo/20190915-list_of_kernels\\n\'
8677 b\'/home/giampaolo/20190916-installed_packages\\n\'
8678 b\'/home/giampaolo/find_3_days\\n\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end