#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/.*(?=\\)"
Local $sString = "8670 b'/home/giampaolo/Nextcloud/KJ/risorse varie/ricerche/pdf/Screenshot_20181203_163257.xcf\n'" & @CRLF & _
"8671 b'/home/giampaolo/Nextcloud/KJ/risorse varie/20181122_120359-Kickstarter-online.png\n'" & @CRLF & _
"8672 b'/home/giampaolo/Nextcloud/Komatsu.mp4\n'" & @CRLF & _
"8673 b'/home/giampaolo/20190609rsync_HM-1_4T\n'" & @CRLF & _
"8674 b'/home/giampaolo/Prada-1913_HK.ods\n'" & @CRLF & _
"8675 b'/home/giampaolo/2019 09 12 Registrazione EPO.pdf\n'" & @CRLF & _
"8676 b'/home/giampaolo/20190915-list_of_kernels\n'" & @CRLF & _
"8677 b'/home/giampaolo/20190916-installed_packages\n'" & @CRLF & _
"8678 b'/home/giampaolo/find_3_days\n'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")