import Foundation
let pattern = #"IBEX Auction \(Buyers\) \((Nov)-(Dec)\)-(16) Baseload"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
IBEX Auction (Buyers) (01.11-30.11).2017 Baseload
IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload
IBEX Auction (Buyers) Sep-17 Baseload
IBEX Baseload Aug-17
IBEX Baseload 2018
IBEX Baseload Half Year 1 - 2018
IBEX Baseload Wk30 17
IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload
IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload
IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload
IBEX Auction (Buyers) (11-28).02.2017 Baseload
IBEX Auction (Buyers) 2017 Baseload
IBEX Auction (Buyers) Q1-17 Baseload
IBEX Auction (Buyers) (Nov-Dec)-16 Baseload
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)