using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IBEX Auction \(Buyers\) \((Nov)-(Dec)\)-(16) Baseload";
string input = @"IBEX Auction (Buyers) (01.11-30.11).2017 Baseload
IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload
IBEX Auction (Buyers) Sep-17 Baseload
IBEX Baseload Aug-17
IBEX Baseload 2018
IBEX Baseload Half Year 1 - 2018
IBEX Baseload Wk30 17
IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload
IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload
IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload
IBEX Auction (Buyers) (11-28).02.2017 Baseload
IBEX Auction (Buyers) 2017 Baseload
IBEX Auction (Buyers) Q1-17 Baseload
IBEX Auction (Buyers) (Nov-Dec)-16 Baseload";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}