# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"IBEX Auction \(Buyers\) \((Nov)-(Dec)\)-(16) Baseload"
test_str = ("IBEX Auction (Buyers) (01.11-30.11).2017 Baseload\n"
"IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload\n"
"IBEX Auction (Buyers) Sep-17 Baseload\n"
"IBEX Baseload Aug-17\n"
"IBEX Baseload 2018\n"
"IBEX Baseload Half Year 1 - 2018\n"
"IBEX Baseload Wk30 17\n"
"IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload\n"
"IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload\n"
"IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload\n"
"IBEX Auction (Buyers) (11-28).02.2017 Baseload\n"
"IBEX Auction (Buyers) 2017 Baseload\n"
"IBEX Auction (Buyers) Q1-17 Baseload \n"
"IBEX Auction (Buyers) (Nov-Dec)-16 Baseload")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.