#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "IBEX Auction \(Buyers\) \((Nov)-(Dec)\)-(16) Baseload"
Local $sString = "IBEX Auction (Buyers) (01.11-30.11).2017 Baseload" & @CRLF & _
"IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload" & @CRLF & _
"IBEX Auction (Buyers) Sep-17 Baseload" & @CRLF & _
"IBEX Baseload Aug-17" & @CRLF & _
"IBEX Baseload 2018" & @CRLF & _
"IBEX Baseload Half Year 1 - 2018" & @CRLF & _
"IBEX Baseload Wk30 17" & @CRLF & _
"IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload" & @CRLF & _
"IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload" & @CRLF & _
"IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload" & @CRLF & _
"IBEX Auction (Buyers) (11-28).02.2017 Baseload" & @CRLF & _
"IBEX Auction (Buyers) 2017 Baseload" & @CRLF & _
"IBEX Auction (Buyers) Q1-17 Baseload " & @CRLF & _
"IBEX Auction (Buyers) (Nov-Dec)-16 Baseload"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")