import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "IBEX Auction \\(Buyers\\) \\((Nov)-(Dec)\\)-(16) Baseload";
final String string = "IBEX Auction (Buyers) (01.11-30.11).2017 Baseload\n"
+ "IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload\n"
+ "IBEX Auction (Buyers) Sep-17 Baseload\n"
+ "IBEX Baseload Aug-17\n"
+ "IBEX Baseload 2018\n"
+ "IBEX Baseload Half Year 1 - 2018\n"
+ "IBEX Baseload Wk30 17\n"
+ "IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload\n"
+ "IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload\n"
+ "IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload\n"
+ "IBEX Auction (Buyers) (11-28).02.2017 Baseload\n"
+ "IBEX Auction (Buyers) 2017 Baseload\n"
+ "IBEX Auction (Buyers) Q1-17 Baseload \n"
+ "IBEX Auction (Buyers) (Nov-Dec)-16 Baseload";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}