// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"IBEX Auction \(Buyers\) \((Nov)-(Dec)\)-(16) Baseload").unwrap();
let string = "IBEX Auction (Buyers) (01.11-30.11).2017 Baseload
IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload
IBEX Auction (Buyers) Sep-17 Baseload
IBEX Baseload Aug-17
IBEX Baseload 2018
IBEX Baseload Half Year 1 - 2018
IBEX Baseload Wk30 17
IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload
IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload
IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload
IBEX Auction (Buyers) (11-28).02.2017 Baseload
IBEX Auction (Buyers) 2017 Baseload
IBEX Auction (Buyers) Q1-17 Baseload
IBEX Auction (Buyers) (Nov-Dec)-16 Baseload";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}