use strict;
my $str = 'IBEX Auction (Buyers) (01.11-30.11).2017 Baseload
IBEX Auction (Buyers) (15.06 - 31.08).2017 Baseload
IBEX Auction (Buyers) Sep-17 Baseload
IBEX Baseload Aug-17
IBEX Baseload 2018
IBEX Baseload Half Year 1 - 2018
IBEX Baseload Wk30 17
IBEX Auction (Buyers) (01.07.2017 - 30.06.2018) Baseload
IBEX Auction (Buyers) (01.07 - 30.09).2017 Baseload
IBEX Auction (Buyers) (15.06 – 15.09).2017 Baseload
IBEX Auction (Buyers) (11-28).02.2017 Baseload
IBEX Auction (Buyers) 2017 Baseload
IBEX Auction (Buyers) Q1-17 Baseload
IBEX Auction (Buyers) (Nov-Dec)-16 Baseload';
my $regex = qr/IBEX Auction \(Buyers\) \((Nov)-(Dec)\)-(16) Baseload/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}