// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(https?\:\/\/)?(www)?(m|dev)?(\.)?aladdinbailbonds\.com").unwrap();
let string = "https://locations.aladdinbailbonds.com
https://www.aladdinbailbonds.com/
http://www.aladdinbailbonds.com/
aladdinbailbonds.com
www.aladdinbailbonds.com
https://m.aladdinbailbonds.com/
locations.aladdinbailbonds.com
www.locations.aladdinbailbonds.com
https://dev.aladdinbailbonds.com/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}