import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?\\:\\/\\/)?(www)?(m|dev)?(\\.)?aladdinbailbonds\\.com";
final String string = "https://locations.aladdinbailbonds.com\n"
+ "https://www.aladdinbailbonds.com/\n"
+ "http://www.aladdinbailbonds.com/\n"
+ "aladdinbailbonds.com\n"
+ "www.aladdinbailbonds.com\n"
+ "https://m.aladdinbailbonds.com/\n"
+ "locations.aladdinbailbonds.com\n"
+ "www.locations.aladdinbailbonds.com\n"
+ "https://dev.aladdinbailbonds.com/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}