use strict;
my $str = 'https://locations.aladdinbailbonds.com
https://www.aladdinbailbonds.com/
http://www.aladdinbailbonds.com/
aladdinbailbonds.com
www.aladdinbailbonds.com
https://m.aladdinbailbonds.com/
locations.aladdinbailbonds.com
www.locations.aladdinbailbonds.com
https://dev.aladdinbailbonds.com/
';
my $regex = qr/^(https?\:\/\/)?(www)?(m|dev)?(\.)?aladdinbailbonds\.com/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}