$re = '/^(https?\:\/\/)?(www)?(m|dev)?(\.)?aladdinbailbonds\.com/m';
$str = 'https://locations.aladdinbailbonds.com
https://www.aladdinbailbonds.com/
http://www.aladdinbailbonds.com/
aladdinbailbonds.com
www.aladdinbailbonds.com
https://m.aladdinbailbonds.com/
locations.aladdinbailbonds.com
www.locations.aladdinbailbonds.com
https://dev.aladdinbailbonds.com/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);