using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?\:\/\/)?(www)?(m|dev)?(\.)?aladdinbailbonds\.com";
string input = @"https://locations.aladdinbailbonds.com
https://www.aladdinbailbonds.com/
http://www.aladdinbailbonds.com/
aladdinbailbonds.com
www.aladdinbailbonds.com
https://m.aladdinbailbonds.com/
locations.aladdinbailbonds.com
www.locations.aladdinbailbonds.com
https://dev.aladdinbailbonds.com/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}