re = /^(https?\:\/\/)?(www)?(m|dev)?(\.)?aladdinbailbonds\.com/m
str = 'https://locations.aladdinbailbonds.com
https://www.aladdinbailbonds.com/
http://www.aladdinbailbonds.com/
aladdinbailbonds.com
www.aladdinbailbonds.com
https://m.aladdinbailbonds.com/
locations.aladdinbailbonds.com
www.locations.aladdinbailbonds.com
https://dev.aladdinbailbonds.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end