#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?\:\/\/)?(www)?(m|dev)?(\.)?aladdinbailbonds\.com"
Local $sString = "https://locations.aladdinbailbonds.com" & @CRLF & _
"https://www.aladdinbailbonds.com/" & @CRLF & _
"http://www.aladdinbailbonds.com/" & @CRLF & _
"aladdinbailbonds.com" & @CRLF & _
"www.aladdinbailbonds.com" & @CRLF & _
"https://m.aladdinbailbonds.com/" & @CRLF & _
"locations.aladdinbailbonds.com" & @CRLF & _
"www.locations.aladdinbailbonds.com" & @CRLF & _
"https://dev.aladdinbailbonds.com/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")