// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<a(.+?(href=["'](.+?)["'])?)?.*?>(.*?)<\/a>"#).unwrap();
let string = "<a name=\"asdsad\"></a>sad sa <a href=\"http://wdsad\" name=\"sadasd\">asd</a> <a href='sdfsdfdsf'>asdasd</a>sadsad<a>asdasd</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}