package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a(.+?(href=["'](.+?)["'])?)?.*?>(.*?)<\/a>`)
var str = `<a name="asdsad"></a>sad sa <a href="http://wdsad" name="sadasd">asd</a> <a href='sdfsdfdsf'>asdasd</a>sadsad<a>asdasd</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}