import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a(.+?(href=[\"'](.+?)[\"'])?)?.*?>(.*?)<\\/a>";
final String string = "<a name=\"asdsad\"></a>sad sa <a href=\"http://wdsad\" name=\"sadasd\">asd</a> <a href='sdfsdfdsf'>asdasd</a>sadsad<a>asdasd</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}