$re = '/<a(.+?(href=["\'](.+?)["\'])?)?.*?>(.*?)<\/a>/i';
$str = '<a name="asdsad"></a>sad sa <a href="http://wdsad" name="sadasd">asd</a> <a href=\'sdfsdfdsf\'>asdasd</a>sadsad<a>asdasd</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);