re = /<a(.+?(href=["'](.+?)["'])?)?.*?>(.*?)<\/a>/i
str = '<a name="asdsad"></a>sad sa <a href="http://wdsad" name="sadasd">asd</a> <a href=\'sdfsdfdsf\'>asdasd</a>sadsad<a>asdasd</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end