#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a(.+?(href=["'](.+?)["'])?)?.*?>(.*?)<\/a>"
Local $sString = "<a name="asdsad"></a>sad sa <a href="http://wdsad" name="sadasd">asd</a> <a href='sdfsdfdsf'>asdasd</a>sadsad<a>asdasd</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")