using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a(.+?(href=[""'](.+?)[""'])?)?.*?>(.*?)<\/a>";
string input = @"<a name=""asdsad""></a>sad sa <a href=""http://wdsad"" name=""sadasd"">asd</a> <a href='sdfsdfdsf'>asdasd</a>sadsad<a>asdasd</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}