// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d").unwrap();
let string = "Number to call (514) 723-4383
The office number is 432-763-3456
call 643 771-4453 tomorrow.
Jack's number is (765) 452/1243.
The central number is 871/445/6197
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}