using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d";
string input = @"Number to call (514) 723-4383
The office number is 432-763-3456
call 643 771-4453 tomorrow.
Jack's number is (765) 452/1243.
The central number is 871/445/6197
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}